Multiple organizations for on-premise Sentry

I’m running on-premise installation of Sentry, deployed to Kubernetes cluster with these helm-charts: GitHub - sentry-kubernetes/charts: Easily deploy Sentry on your Kubernetes Cluster

At the moment I’m having difficulties to enable multiple organizations. I tried navigating to /organizations/new route, inputting name for new organization and submitting but I only get an error Please check all input fields are valid. This error will repeat with every possible name that I have tried and there are no spaces, special characters or numbers in organization name.

Configmap of my on-premise setup has set variable SENTRY_SINGLE_ORGANIZATION = False but changing it’s value to True and restarting pods did not help. There are no errors in logs of sentry-web or sentry-nginx.

Do you have any ideas what could be the issue here?

Screenshot of the new organization page:

I do not know which version of Sentry you are using so this might be a bug in an older version. FYI we also do not provide support for the Helm chart you are using as we do not maintain it ourselves.

Now, if you want to use Sentry with multiple orgs, you should definitely set SENTRY_SINGLE_ORGANIZATION to False and then restart all Sentry containers. I recommend doing this first and setting sentry from scratch as I’m not sure how this would affect the initial setup.

I have reinstalled Sentry from scratch now with SENTRY_SINGLE_ORGANIZATION set as False and ran into new problems.

There are no users in sentry database to begin with and I’m unable to register. When I created a new user by logging into sentry-web pod and tried to login, I ran into new issue “You do not have access to any organizations within Sentry.”:

From sentry_organizations table I can see that sentry organization exists but I’m somehow unable to access it.

When I try to navigate to /organizations/new to create another organization, there is still a very brief error message Unable to save your changes. Please ensure all fields are valid before continuing.

In sentry-web logs there are no errors visible.


Update: By navigating into Admin → Organizations → Sentry I can create new projects and teams under Sentry-organization, but there is still no way to create new organizations.

Did you create the super user from the command line?

Yes, I created new user from command line with $ sentry createuser and made it superuser.

And is that the account you are using for all this stuff?

Yes. There is only one user at the moment and that’s the one I created on command line.

Hi, sorry for the frustration. Can you try the following steps:

  • Add auth.allow-registration: true to your sentry/config.yml file
  • Run docker-compose restart web
  • Try registering a new user and see if it asks you to create a new org