Can't set up saml or auth0


#1

When following the steps outlined here Saml provider not available (apt packages + pip install), I get auth providers enabled in Sentry. However, both the auth0 and SAML providers error out under configuration with the same error:
OneLogin_Saml2_Error: Invalid dict settings: sp_acs_url_invalid,sp_sls_url_invalid

From that issue I get the impression that setting SENTRY_FEATURES['organizations:sso-saml2'] = True is all that should be needed without any explicit pip installs, but that’s not what I’m seeing.

I guess I’m looking for:

  • explicit instructions to get saml and other providers working right
  • any feedback on the above exception - is this because my auth providers aren’t installed correctly or is something else going on?

#2

@evanpurkhiser anything obvious here to you? I dont think we have any specific settings on sentry.io.


#3

@trondhindenes: A guess might be something wonky with your system url prefix. You could drop a print here and see what the ACS and SLS urls look like:


#4

That makes perfect sense, thanks. My instance was a local test instance just running in Docker, so there’s every change I didn’t pay enough attention to getting the URLs right.

I’ll prep a proper deployment in Kubernetes with the correct urls and see if the problem persists. Thanks!!


#5

btw, I also had to run “sentry django migrate” in order to activate auth providers, it wasn’t enough to pip install the required packages + set the SENTRY_FEATURES flag.


#6

@trondhindenes you should generally always run ‘sentry upgrade’ (vs using the South-native command which is ‘sentry django migrate’)


#7

You’re right. I was stumped by the fact that it looks for a config file in current directory from where those commands are run - that’s why I couldn’t get a consistent result.