[React Native] Crash report from native iOS is not symbolicatd

#1

Our crash report does not show correct information, it shows <redacted> and the address is hard to understand

Out project auto upload DSYM file everytime we build, I also tried manual upload the DSYM file but it didn’t work. I also turn on Reprocessing but no luck

Am I doing something wrong?

0 Likes

#2

What version of iOS was this crash?

CoreFoundation and Foundation are iOS “system” frameworks meaning you are doing everything right, if you see something like this, it means that we are missing the symbols.

If it was iOS 12.2 it should be fixed by now, we did update it yesterday.

0 Likes

#3

@HazAT Thank for replying
It happened for various iOS versions from 11.4 to 12.1.
Yeah, I understand that I’m missing symbols. But our build script upload dSym file everytime we build release. It shows on the list of debug files.


Could you think of anything else that makes it cannot symbolicate?

0 Likes

#4

Are you using on-premise?

0 Likes

#5

No, we don’t use it. Should we use it?

0 Likes

#6

Oh no, we use sentry.io. We don’t host it ourself.

0 Likes

#7

OK, can you please link to one event here so we can check what’s going on?

0 Likes

#8

Event link here https://sentry.io/organizations/employment-hero/issues/649313100/events/51277148826/

0 Likes

#9

Thank you, I just checked, we are missing 12.1.3 and 12.1.4 system symbols, I will upload them today.

1 Like

#10

Thank you for quick responding. There are issues on other OS version too. Could you please have a look too
https://sentry-host/organizations/employment-hero/issues/716266222/events/1f11d3d376dd43b2bd82747250209330/

0 Likes

#11

We are working on a fix for this, stay tuned.

1 Like

#12

Hey, so we fixed the issue and stack traces should be symbolicated correctly now.

0 Likes

#13

Stacktrace is still not be symbolicated for both old events and new events.

could you have a look?
The event link https://sentry-host/organizations/employment-hero/issues/964972629

0 Likes

#14

The link you posted looks symbolicated for me

0 Likes

#15

can it be a different data display between accounts? Since there is nothing like that on my side.
Another event just happened this morning

0 Likes

#16

Seeing redacted here means that symbols for your app are missing now, these aren’t system symbols. You have to upload the debug symbols of your app.

0 Likes

#17


As you can see, we use the sentry script to upload debug symbols when builds. I’m not sure if we need anything else.

0 Likes

#18

Sorry, can you link to an individual event again, I can’t find any of those unsymbolicated events.

0 Likes

#19

That’s weird. All of my events are unsymbolicated . Is it a different view between accounts?

Event link: https://sentry-host/organizations/employment-hero/issues/716266222/events/07535038924a4c6491e0dfa5597464d9/
https://sentry-host/organizations/employment-hero/issues/649313100/events/906abac833ae40e5b2ddb04fbfae0721/

0 Likes

#20

The two events are symbolicated

Can you post how it looks for you, I am curious now

0 Likes