Sentry using a deprecated GitHub API endpoint

We received the following warning email from GitHub regarding our Sentry on-premise server running Sentry 10.1.0.dev0fc9a46f. Wondering if this deprecated endpoint reference has been replaced in an updated version?

Hi @keymanapp Admin,

On July 9th, 2020 at 11:01 (PDT) the application “keyman-sentry” owned by your organization issued a request using the deprecated endpoint for creating access tokens. GitHub has deprecated this undocumented endpoint, its replacement which accepts the same arguments is available now.

This endpoint will be removed on October 1st, 2020.

Please visit https://developer.github.com/changes/2020-04-15-replacing-create-installation-access-token-endpoint for more information about suggested changes, brownouts, and removal dates.

Thanks,
The GitHub Team

Hey there! It has not been updated yet but it’s scheduled to be updated very soon. Will let you know when it is updated.

1 Like

Hey,

20.7.0 will be out tomorrow the 15th with the endpoints updated.

4 Likes