Setup Bitbucket Integration

I am finishing setting up our sentry on premise server and I am having difficulty getting bit bucket integration to work. I’m assuming its a configuration error on my part so here is what I have.

I set the bitbucket env varaibles
BITBUCKET_CONSUMER_KEY = “secret-key”
BITBUCKET_CONSUMER_SECRET = “secret”

I made sure that the system.url-prefix is set correctly.

Set these permissions in bitbucket.
image

On bitbucket auth page everything looks fine.

When I click on grant access I get a HTTP ERROR 405 before the popup window closes.

In the sentry internal project I see a couple errors for it
https://sentry.wallsmetalroofing.com/share/issue/1d751b844a43460bb246ea1be5258a61/

The server in question is running centos 7 with docker 19.03.2 and python 2.7.16.

Is there anything else that I am missing as to why I can’t integrate with bitbucket? I am not hosting the bitbucket instance…

Trying some more stuff…

I tried the bitbucket varaibles in the sentry.conf.py file, in the .env file and neither made a difference. Then I tried a incorrect value in both the key and secret and the same result. So where should I be putting those values. It seems as if the values don’t matter or aren’t being used.

1 Like