Connect 2fa not work

The problem is that, when I try to send to mail for to connect 2FA , I never recived this mail. ¿Can you help me?

Can you check your mail settings and try to send a test email first?

My config is ok in config.yml but I dont recived any mail. My config.yml

###############
# Mail Server #
###############

# mail.backend: 'smtp'  # Use dummy if you want to disable email entirely
#mail.host: 'smtp'
mail.host: 'smtp.gmail.com'
mail.port: 587
mail.username: 'noreply@.......com'
mail.password: '.............'
mail.use-tls: true

# The email address to send on behalf of
mail.from: 'noreply@........com'

Could this be the issue? What do you see when you try to send a test email from the admin panel?

It doesn’t do anything, no errors, nothing, that email is not valid, why? I tried to use the default configuration before modifying the smtp part in the config.yml and it didn’t do anything either.