Email notifications not being sent


#1

I’ve set up a basic Sentry 8.11 instance and have been able to catch errors from my React+Redux app, but for some reason it doesn’t send email notifications at all. I’ve got Docker containers for redis, smtp, and postgres running as per the installation instructions, but I’m not sure what was wrong with my setup. Help?

Here is the mail section of my config.yml:

###############
# Mail Server #
###############

# mail.backend: 'smtp'  # Use dummy if you want to disable email entirely
# mail.host: '129.73.15.191'
# mail.port: 25
# mail.username: ''
# mail.password: ''
# mail.use-tls: false
# The email address to send on behalf of
# mail.from: 'nikhilshenoy17@gmail.com'

# If you'd like to configure email replies, enable this.
# mail.enable-replies: false

# When email-replies are enabled, this value is used in the Reply-To header
# mail.reply-hostname: ''

# If you're using mailgun for inbound mail, set your API key and configure a
# route to forward to /api/hooks/mailgun/inbound/
# mail.mailgun-api-key: ''

#2

Well, first of all, everything here is commented out. You should uncomment the stuff you want to use.


#3

Good point. And where would I be able to configure who receives the emails?


#4

This is entirely configurable within Sentry the product. It’s really hard to simply answer that since there are lots of different ways.


#5

I’ve added members to my projects along with their emails through the project settings. Is there anything else I need to do to get this feature to work?


#6

Unlikely, notifications should be enabled by default.


#7

I have the same issue
I am using Sentry 9.0.0 in docker and not receive any email ,I can see the issue in dashboard but no emails
here is my configuration:

###############
# Mail Server #
###############

 mail.backend: 'smtp'  # Use dummy if you want to disable email entirely
 mail.host: 'smtp.gmail.com'
 mail.port: 587
 mail.username: 'myemail@gmail.com'
 mail.password: 'mypass'
 mail.use-tls: true
# The email address to send on behalf of
 mail.from: 'myemail@gmail.com'

should we change something else?


#8

BTW - with the docker deployment - you should really use environment variables as per the documentation here:

So you would define SENTRY_EMAIL_HOST etc. when you run your container


#9

smtp.gmail.com


#10

Sorry this typo is just here not in my code,I got email from google which is related to security level,I Changed Allow less secure apps: ON as well ,but still no emails.


#11

it works ,the emails where in my spam :slight_smile: