How to configure Jira Cloud in your on-premise Sentry

To use Jira Cloud and on-prem Sentry together requires a couple additional steps for setup:

1. Create an [ Atlassian development account ](https://developer.atlassian.com/cloud/jira/platform/getting-started/)

2. Enable development mode in your Jira instance under Gear Icon > Manage Apps > Settings

3. Upload the Atlassian connect descriptor to Jira. It can be found at:
https://[your-domain]/extensions/jira/descriptor/ or in Sentry’s case: https://sentry.io/extensions/jira/descriptor/

Click on ‘Settings’

Click on ‘Apps’

Click on ‘Manage Apps’

Click ‘Upload app’

Once you get here, you’ll need to add your Atlassian connector descriptor into this field from a public domain. Jira will turn that into a JSON file that Jira will use to install the integration.

4. Find the Sentry Add-on that you just installed and click ‘Configure’ to begin the setup process in Jira.

The app key will show your public domain, and let you continue by clicking ‘Configure’. From here, you will be in your regular Jira Cloud flow.

Keep in mind: this is available on Sentry versions 9.1.0 or higher.

Went through this install procedure, and it installs fine. But when I try to link/create a jira issue it doesn’t seem to be able to search for the Reporter field nor the Assignee field. The projects field, however, is populated with lots of projects, so that part works. Without Reporter it’s impossible to complete the form, so this integration is not working.
Version 9.1.1 Sentry on premise and Jira Cloud.

Hey Jack - so sorry this isn’t working for you. Can you please email us at support@sentry.io? We’ll troubleshoot and help figure this out for you.

thanks, emailed.

Update: Unfortunately support believes this is only issues on my environment. Please post here if you are also having this issue.

I’ve tried this method after I tried the marketplace plugin. But the installation process fails with the error message “The app “sentry.io.jira” could not be installed as a local app as it has previously been installed from Atlassian Marketplace”

Hi, following your instructions above. When I try to click the configure button in jira cloud, the process freezes at this step “App is not responding. Wait or cancel?” Maybe I misconfigured something? please any help will be sentry sentry version 9.1.1.
image

We have totally the same situation.

Worked fine for us. Make sure you’re using the connect descriptor from your domain (NOT the link to Sentry’s!) and that you can successfully resolve that on the public internet.