Jira integration broken on latest onpremise?

Hi there,

We are running the latest, or very close to latest onpremise Sentry in docker: Sentry 20.12.0.dev055c4673. When I try to connect Jira to our instance I get the " Finish integration installation" with the single organization that exists already selected and a button to “Install Jira”.

The problem is that clicking the button does nothing.

The first time this happened an error was logged to the internal project in Sentry:

Clicking it again doesn’t trigger the error. Any way to retry, assuming that it was some temporary issue? Am I doing something wrong here, or should I try to report this on Github?

Thanks

Hi, we’ll look into this but to speed things up: were you using an earlier version that this used to work before? If so which version was it?

Also, are you using this with Python 3 or Python 2?

@amir-hadzic This is Jira Cloud, yea? Can you try re-uploading the app descriptor and restart the installation process?

Also a full stack trace would be helpful so I can see where the stack starts

1 Like

Thanks for the replies.

We used this before on Sentry 9.2 but since then we removed all docker volumes and made a fresh installation with latest Sentry mentioned above.

We are using the default docker images, so Python 3.

This is Jira Cloud, yes.

I’ve tried installing the integration again via Jira Cloud and got the same error. Here are the breadcrumbs from the reported error, if that helps:

Let me know if I can somehow provide more information.

Thanks

It looks like you aren’t going to the next step where you connect your Sentry organization to the integration. Make sure after you upload the file descriptor, you press “configure” and press the “Finish installation” button.