Sentry 10 and Jira 7.7 self-hosted

Hi,

We are currently using Sentry 8.22 and I’m trying to do a fresh install of Sentry 10.

Unfortunately, I’m having an issue with Jira integration. With our current version, we can use a user/password to connect to Jira, but it doesn’t seem to be possible now or I’ve missed something ?! And of course, we are using an old Jira and I have no admin access to it.

Is there a way to have the old integration back ?

Thanks in advance.
Kind Regards,
Yohan

The old integration is still live at https://github.com/getsentry/sentry/blob/b6cddd6436834403448078e83d0c411ccbf233d4/src/sentry_plugins/jira/plugin.py - are you able to use it?

How should I use it ?
In Legacy integrations I only see Jira Atlassian Connect.

@iskology Hi there, thanks for writing in. We hide the older Jira legacy integration because we have a new one to replace it. The new one spans all your projects instead of being set up per project. If you are using Jira on-prem, I recommend you check out the new Jira server integration (https://docs.sentry.io/workflow/integrations/global-integrations/#jira-server). If you really can’t use that one and need to use the legacy one, you need to manually go the URL: https://{your_sentry}/settings/{your_org}/projects/{your_project}/plugins/jira/ where you replace those variables with your values.

1 Like

Thanks @scefali I can see the old Jira integration now.
But for some reason I get a 400 error after I save the configuration and there is no event in the internal project to try to understand what is going on.

@iskology you get a 400 error trying to save the configuration? There might be an error message for the web request if you open up the network tab. If you could find that, it might help me understand why it doesn’t work.

I don’t understand what is the problem. For the 3 fields I get this error “This field is required” but they are filled…

Request Headers

PUT /api/0/projects/sentry/sandbox/plugins/jira/ HTTP/1.1
Host: <sentry.domain>:9000
Connection: keep-alive
Content-Length: 51
Pragma: no-cache
Cache-Control: no-cache
Accept: application/json; charset=utf-8
X-CSRFToken: WS6bsxUR2VnvRv9thVrJcgqyR66222ThuXxkLRQHGWIIoJKYaPyfu56PiFleD7LR
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Content-Type: application/json
Origin: http://<sentry.domain>:9000
Referer: http://<sentry.domain>:9000/settings/sentry/projects/sandbox/plugins/jira/
Accept-Encoding: gzip, deflate
Accept-Language: en-US,en;q=0.9
Cookie: sc=WS6bsxUR2VnvRv9thVrJcgqyR66222ThuXxkLRQHGWIIoJKYaPyfu56PiFleD7LR; sudo="CnuHybxh75Et:1jcqX8:e7u_TskU5sYuGLqT89-yQkljNtg"; sentrysid=".eJxNjrFOwzAQhtO6FFGBkHgEpkxRndhJMxZUCRa2g2yRY7vEJMQ4tks7VOLRCSVDt9P33333_0yPZhLCTcm8q0tvZV8qUUyCIMBwxbhTO6n792I-ACs71x9gZr3QxfUAHjv_dKj2dUY3rlgMwEnruNaNkqeDb903UsDdmbtivJGdgPt_WeSdam30l0ebT6ba9TA9jDvIWj02uT1T1MzWEHKKM5JhLmKM44TxhEpOKCNpxmTFxJZtRSoqGgMqrT-aaQjI6cagU_Hn-q1N8fojf9m9mhkgJVpzAQtM82USrwjOAXklzHz8juT-y1yOOVlmdOV99AskKV3M:1jcqbL:qNsw--eWeyFElDMYb-9-jJObcY8"; su="IhWl61Aj9NvV:1jcqbL:xCgKBq2Cu2aEBdxiM-cvkOEb2Oc"

Request payload

{"default_issue_type":null,"default_priority":null}

Response Headers

HTTP/1.1 400 Bad Request
Server: nginx/1.16.1
Date: Sun, 24 May 2020 13:24:06 GMT
Content-Type: application/json
Content-Length: 121
Connection: keep-alive
Access-Control-Allow-Headers: X-Sentry-Auth, X-Requested-With, Origin, Accept, Content-Type, Authentication, Authorization, Content-Encoding
X-Content-Type-Options: nosniff
Content-Language: en
Access-Control-Expose-Headers: X-Sentry-Error, Retry-After
Vary: Accept-Language, Cookie
X-XSS-Protection: 1; mode=block
Allow: GET, POST, PUT, DELETE, HEAD, OPTIONS
Access-Control-Allow-Origin: http://<sentry.domain>:9000
Access-Control-Allow-Methods: GET, POST, PUT, DELETE, HEAD, OPTIONS
X-Frame-Options: deny
Set-Cookie: sentrysid=".eJxNjrFOwzAQhtO6tKICIfEITJmiOrGTdiyoEixsB9kix3aJSYhxbJd2qMSjE9oM3U7ff_fd_zs-mlEItwXzriq8lV2hRD4KggDDNeNO7aTuPvJpD6xsXXeAifVC5zc9eGr986HcVxnduHzeAyet41rXSp4OfnRXSwH3F-6S8Vq2Ah7Ossg71djoP482X0w16356HHaQtXpocnehqJitIOQUZyTDXMQYxwnjCZWcUEbSjMmSiS3bilSUNAZUWH804xCQ07VBp-Iv1XuT4vXn6nX3ZiaAlGjMFcwxXS2SeElICsgrYabDdyT332Y25GSR0aX30R8kLF3M:1jcqbm:g60DPMpKpHnOI-0rMISTmcZNrpw"; expires=Sun, 07-Jun-2020 13:24:06 GMT; httponly; Max-Age=1209600; Path=/
Set-Cookie: su="IhWl61Aj9NvV:1jcqbm:CHkDJHC6RKEc3POeul4GFwRzQUM"; httponly; Path=/

Response payload

{"errors":{"username":"This field is required.","password":"Field is required","instance_url":"This field is required."}}

@iskology The problem is that there is a pretty bad bug that prevents you from saving the form. I just tested this myself and I see the same problem. I do apologize that you had to encounter this bug. Unless there is a way for you to use the new Jira server integration by getting admin privileges, I don’t think there is a workaround.