Postgres 9.2 compatibility?


#1

Apologies if this has been asked elsewhere and feel free to supply a link to a different thread.

I’m just doing a VM setup and I see for docker install Postgres 9.5 is supplied. Currently for Centos 7, the repo supports version 9.2. Will 9.2 work with sentry?

Thanks.


#2

I’m not entirely sure, but we use 9.3 in places in production ourselves. And has been tested in production up to 9.6.


#3

Alright.

I went ahead and starting with the setup. I’ll post up results when I’m done. My IT manager likes things to be handled through our puppet repos, but if I need to I’ll upgrade as this is a one-off for our dev team.

So far I only needed to downgrade redis-py-cluster to 1.3.4 from 1.3.6 and I had to yum install gcc-c++ to get pip install -U sentry to work.


#4

Okay, seems to be all good after some troubleshooting.

One major issue I had was sentry init /etc/sentry didn’t seem to work for me unless I ran sudo -u postgres -i before running SENTRY_CONF=/etc/sentry sentry run [web|worker|cron] commands afterward; just for kicks I did the default ~ path with sentry init and that worked fine. In the end I ended up just creating the 3 systemd services so it didn’t matter once sentry web, worker and cron were started as services.

So the short answer is Postgres 9.2 works if anyone should stumble upon my post.


#5

I believe that’s because the default connection is probably socket based, and grants access to the postgres UID. You could resolve that by changing your postgres connection credentials and wiring that up in the sentry config.


#6

Alright, thanks for the tip. Before this week I had zero postgres experience and the week before was my first taste of a LAMP stack with mysql. The life of a sys admin hehe. Never gets dull and plenty of stress.