Jira: Connect to Sentry doesn't register successful login

Sentry cloud, Jira cloud.

Installed the Sentry app in Jira. Under Manage Apps: Sentry: Configure, it shows

Please login to your Sentry account to access the Sentry Add-on configuration
You may also need to enable 3rd-party cookies in your browser
You must disable your ad-blocker to install this integration, as it relies on 3rd-party cookies.

Sign In to Sentry

When I click Sign In To Sentry, a new tab opens and I see Sentry. But nothing changes on the Jira App screen. I tried logging out and logging in when requested from the Jira App; I also tried in Chrome Incognito (after enabling 3rd party cookies); same behavior.

Both Jira and Sentry.io are set up for Google auth, so might be running into something related to JIRA login with Google-managed users?.

Any help greatly appreciated.

1 Like

We are also facing this same issue.

Had the same issue, but was able to fix it. Had to do the following:

  • Become owner of the Sentry organization (admin was apparently not enough)
  • When you get to the page in Jira where you click the “Sign In To Sentry”-button, don’t click the button. The link on the button is just to the login page for Sentry and doesn’t seem to do anything. Instead inspect the button and find a link in one of the parent nodes which goes like https://sentry.io/extensions/jira/configure?xdm_e=… (followed by a link to your Jira project and a bunch of other params), take that entire link and replace the link on the button. And then click the button.

After doing that I was able to go through the steps for connecting Jira and Sentry.