JIRA login with Google-managed users?

Hi! I’m trying to integrate our JIRA instance with Sentry, but I’m running into an issue: our JIRA users are managed with Google Apps, so they don’t have passwords for the JIRA plugin. (I tried a wide variety of hacky workarounds without success. I also tried the Atlassian Connect Sentry plugin, but it seems to not have any affect–is that only for JiRA Service Desk?)

What’s the correct way to configure the JIRA plugin when your JIRA users don’t have passwords?

1 Like

Hi! It looks like we got back to you privately through support, but here’s a quick answer for anyone else reading this.

You currently need a JIRA username and password to use our integration, so the only option would be to change your JIRA settings to allow that. The way our integration works, you only need one JIRA user/password per Sentry project, so many people just create a separate JIRA account for use with Sentry.

The Atlassian Connect plugin is a UI widget within JIRA that displays Sentry errors recently experienced by the reporter of the JIRA issue.

Hello @jess,

I acknowledge this issue is quite old, but I’m hoping that keeping the conversation going about Google managed JIRA integrations here is appropriate.

Like @shosti, our company uses Google SSO for our JIRA and thus doesn’t have an account username and password for a Sentry integration. I’ve asked our JIRA admin if there’s a way we could, as you suggest, create a user with a username and password specifically for these types of integrations. I was told that we use what JIRA calls “GSync” that only allows accounts that are on our company gmail, and that users outside of SSO cannot be created.

With this being said, is there still no way for us to integrate JIRA into our Sentry organization? Is there any plans for SSO integration in the future?

We’re working towards supporting Atlassian Connect, but it’s a fairly large technical change within Sentry. We should have something to show early next year, but will first be launching an overhauled Slack integration to prototype against what we’re calling our ‘Integrations’ API.

1 Like

Awesome! Thanks for the reply, looking forward to these features :slight_smile:

Hi all,

I wanted to check on the latest status with this. In my Sentry project settings I see an Integration called “JIRA Atlassian Connect” but enabling it doesn’t seem to do anything. I’ve also tried generating an API token through Atlassian, and can see that it’s connecting successfully, but Sentry still gives an error.