Minidump MacOS report not appearing in dashboard


We are running Sentry installation on our server. Everything was working fine a year ago. Crashes were being reported and symbolicated properly. At some point, we ran into some issues and paused our Sentry server. Now, we have updated to Sentry 9.1.2. I have been trying to re-enable our Sentry setup. Sentry itself is working fine. Android minidump reports are working fine.

There is a problem with MacOS. Uploading reports for version without debug symbols seems to work. I can see the stacktraces in dashboard. As expected, they are not symbolicated. When I upload debug symbols (.dsym), suddenly reports stop appearing in dashboard. I can see that the number of reports under “Stats” is increasing. But nothing appears in the dashboard itself. I also tried to look under “Processing errors”, but there is nothing there either. Debug symbol upload and minidump upload are both 200 (for the reports I tried uploading through client and manually with curl)

This seems to be related to processing. Is there any way to debug what could be causing this issue?

We have fixed the issue. Turns out the AWS instance wasn’t powerful enough. If I’m not mistaken, my admin said he upgraded to an instance with more RAM. That fixed all the problems with hanging and reports not appearing in dashboard. I think the worker was hanging when trying to symbolicate a crash.